Yeastar Products Are Not Vulnerable to WannaCrypt Ransomware | Yeastar

Infections of the ransomware dubbed “WannaCry” / “Wannacrypt” has spread aggressively over the weekend and it is indicated that over 70 countries have been impacted in some way by the WannaCry worm. This ransomware is widely reported to be based on a tool developed by the NSA to hack into computers and is targeting Microsoft Windows users. Should Yeastar products (Linux-based) users worry about WannaCrypt?

The answer is NO. Yeastar products are not vulnerable to the flaw. Yeastar products are built on embedded Linux to secure the software. But if you are using Windows-based PBX or your PC is running Windows OS, you should be cautious. Installing the Microsoft patch, which prevents exploiting vulnerability in the SMBv1 protocol, is the best method.

What Systems Are Impacted?

WannaCry only targets Microsoft Windows systems and is known to impact the following versions:

  • Microsoft Windows Vista SP2
  • Windows Server 2008 SP2 and R2 SP1
  • Windows 7
  • Windows 8.1
  • Windows RT 8.1
  • Windows Server 2012 and R2
  • Windows 10
  • Windows Server 2016
  • Windows XP

Microsoft has issued a notification that included links to patches for all impacted Windows operating systems. More details about the ransomware can be found on the Microsoft support website.